Discussion:
[dbcp] DBCP2 Under Java 8?
(too old to reply)
Frank
2018-04-23 21:10:42 UTC
Permalink
Hi folks,

The subject says it all! :-)  The DBCP Overview page indicates "DBCP 2
compiles and runs under Java 7 only".  I assume it would be good for
Java 8 as well, but has any testing been done along the Java 8 lines?

Thanks,

-Frank
Matt Sicker
2018-04-23 23:21:37 UTC
Permalink
I've been using DBCP2 in Java 8 for years now. DBCP2 is also used in
Tomcat, and recent versions of Tomcat require Java 8, so it's been well
tested in that realm as well.
Post by Frank
Hi folks,
The subject says it all! :-) The DBCP Overview page indicates "DBCP 2
compiles and runs under Java 7 only". I assume it would be good for Java 8
as well, but has any testing been done along the Java 8 lines?
Thanks,
-Frank
--
Matt Sicker <***@gmail.com>
Gary Gregory
2018-04-23 23:58:25 UTC
Permalink
I've been building DBCP2 locally with Java 8 and all is well.

Gary
Post by Matt Sicker
I've been using DBCP2 in Java 8 for years now. DBCP2 is also used in
Tomcat, and recent versions of Tomcat require Java 8, so it's been well
tested in that realm as well.
Post by Frank
Hi folks,
The subject says it all! :-) The DBCP Overview page indicates "DBCP 2
compiles and runs under Java 7 only". I assume it would be good for
Java 8
Post by Frank
as well, but has any testing been done along the Java 8 lines?
Thanks,
-Frank
--
Loading...